読者です 読者をやめる 読者になる 読者になる

CentOS6にphp5.2をインストールする

訳あって、php5.3がインストールされたCentOS6に、php5.2をインストールしなくてはならなくなった。

最初、yumでインストールしようとして、検索して出てきたリポジトリを見てみたが、もうphp5.2は置いていなかった。

 

ので、仕方なくrpmでインストール。

パッケージは

Index of /rhel6/php-5.2/x86_64/

にあったので、必要なものをダウンロード。

 

まず、libeventが必要と怒られるので、先にyumでこれをインストール。

# yum install libevent2

 あとは、順番にインストール

# rpm -ivh php-common-5.2.17-24.el6.x86_64.rpm
# rpm -ivh php-cli-5.2.17-24.el6.x86_64.rpm
rpm -ivh php-5.2.17-24.el6.x86_64.rpm
rpm -ivh php-devel-5.2.17-24.el6.x86_64.rpm
rpm -ivh php-gd-5.2.17-24.el6.x86_64.rpm
rpm -ivh php-mbstring-5.2.17-24.el6.x86_64.rpm
rpm -ivh php-pdo-5.2.17-24.el6.x86_64.rpm
rpm -ivh php-mysql-5.2.17-24.el6.x86_64.rpm

こんな感じで・・・。